Avalara Service Degradation

Incident Report for Chargebee

Resolved

This incident has been resolved.
Posted Jul 21, 2026 - 11:01 UTC

Monitoring

The errors stopped as of 08:25 AM UTC, and we are monitoring the affected systems for stability.
Posted Jul 21, 2026 - 09:24 UTC

Investigating

We are investigating a technical issue with our tax calculation provider, Avalara, that is impacting some subscription renewals and invoicing processes. We are following up with Avalara on this and will keep this incident updated as we progress.
Posted Jul 21, 2026 - 07:52 UTC
This incident affected: Third Party Integrations (Avalara).