HubSpot UI Issues

Incident Report for Chargebee

Resolved

This incident has been resolved.
Posted Jun 24, 2025 - 12:39 UTC

Identified

We are experiencing UI issues with HubSpot Integrations, and our team is working to resolve this. We will provide updates as we make progress.
Posted Jun 24, 2025 - 12:02 UTC
This incident affected: Third Party Integrations (HubSpot).