API Service Degradation - US Region

Incident Report for Chargebee

Resolved

We experienced brief API service interruptions and database connectivity issues in the US region. We are monitoring the endpoints to ensure stability.

Update: The disruptions occurred between 00:30 to 01:32 UTC and 02:43 to 03:52 UTC, during which application connectivity to the database was intermittently impacted.
Posted Jul 09, 2025 - 07:47 UTC
This incident affected: API Endpoints (API (US)).