Checkouts Failing on Safari

Incident Report for Chargebee

Resolved

We have resolved the issue and confirmed that the transactions are now processing as expected. If you continue to experience any issues, please reach out to our support team.
Posted Mar 06, 2025 - 08:23 UTC

Identified

We are investigating an issue where some checkouts are failing on the Safari browser. Our team is working on a resolution. We will provide further updates as more information becomes available.
Posted Mar 06, 2025 - 08:06 UTC