Gift Subscriptions Checkout Failure using Paypal Payments
Incident Report for Chargebee
Postmortem

RCA on Gift Subscriptions Checkout Failure using Paypal Payments
Date Of Incident: 20-Feb-2024

Incident Summary: Customers attempting to make gift subscriptions using PayPal Express Checkout encountered failures due to missing intent ID, resulting in 4xx errors. This issue stemmed from overlooking gift subscriptions during the implementation of intent flow for PayPal Express Checkout. The problem persisted due to the omission of gift subscriptions from impact analysis, leading to a failure to include support for this scenario.

Technical Root Cause: The issue was caused by the lack of a passing intent ID for gift subscriptions when using the new payment method for PayPal Express Checkout. This happened because the intent flow implementation did not include gift subscription payments. As a result, the required intent ID was not provided during checkout, resulting in errors during the payment process.

Impact: Customers were unable to complete gift subscription purchases using PayPal payments, other gateways were functioning BAU.

Remediation and Preventive Measures: As an immediate fix, we have added support in the intent flow for gift subscriptions in PayPal Express Checkout, ensuring that the intent ID is passed correctly during payment processing and fixed the PayPal prism for monitoring to detect any similar issues promptly.

Posted Mar 04, 2024 - 13:08 UTC

Resolved
We discovered an issue where certain customers attempting to make gift subscriptions using PayPal Express Checkout encountered failures due to missing intent ID, resulting in 4xx errors. As an immediate fix, we have implemented support for gift subscriptions within the PayPal Express Checkout payment flow, ensuring all necessary parameters, including intent ID, are correctly passed. We apologize for any inconvenience this may have caused.
Posted Feb 20, 2024 - 10:00 UTC