Google Recaptcha failures in sandbox environment
Incident Report for Chargebee
Resolved
We traced this back to a configuration change that inadvertently affected a few services. We have rolled back the changes and the issue has been resolved.

We apologize for this disruption to service and will continue to drive internal improvements to avoid a similar impact in the future.
Posted Jul 06, 2023 - 08:56 UTC
Identified
We’ve identified what’s causing this issue and we're actively working on restoring the services.
Posted Jul 06, 2023 - 08:17 UTC
Investigating
We are investigating an issue where some customers are experiencing Google Recaptcha validation errors, the impact is only on the TEST sites.
Posted Jul 06, 2023 - 08:10 UTC