API Service Degradation

Incident Report for Chargebee

Resolved

We experienced an issue causing intermittent 5xx errors across all regions, which was traced back to an internal change. We have reverted it to restore full stability. We apologize for any inconvenience this may have caused.

Update:
Impact Window: 10:06 UTC to 10:17 UTC
Posted May 18, 2026 - 11:05 UTC
This incident affected: API Endpoints (API (US), API (EU), API (AU)).