API Service Degradation

Incident Report for Chargebee

Resolved

We have identified that the issue was due to the AWS platform, leading to increased API timeouts. AWS has confirmed that the services have fully recovered. We apologize for any inconvenience caused.
Posted Dec 03, 2025 - 20:01 UTC

Monitoring

API timeouts were observed in the US region during two intervals: 17:44–17:54 UTC and 18:00–18:02 UTC. The services have fully recovered, and we are continuing to monitor system reliability.
Posted Dec 03, 2025 - 19:33 UTC

Identified

We experienced a brief interruption to our API service due to an internal server issue, and we are analysing the impact.
Posted Dec 03, 2025 - 18:24 UTC
This incident affected: API Endpoints (API (US)).