PayPal Service Degradation

Incident Report for Chargebee

Resolved

This incident has been resolved.
Posted Jun 02, 2025 - 19:00 UTC

Monitoring

PayPal has confirmed that the impact has been mitigated as of 18:32 UTC. PayPal is continuing to monitor system performance to ensure stability.
Posted Jun 02, 2025 - 18:58 UTC

Investigating

We are currently experiencing interruptions in the PayPal Payflow services. The PayPal technical team is investigating the issue and working towards a resolution.

For more details on the Incident: https://www.paypal-status.com/history/eventdetails/88111
Posted Jun 02, 2025 - 18:42 UTC
This incident affected: Payment Gateway Processing (PayPal Payment Services).