Service Interruption in the GoCardless Gateway
Incident Report for Chargebee
Resolved
A recent change in our application led to failures in processing collect-invoice and sub-renewal requests via the GoCardless gateway. This was due to incomplete error handling, resulting in null pointer exceptions. We fixed this by addressing how we handle these errors, ensuring transactions can now fail gracefully. We apologize for any inconvenience this may have caused.

Note – The impact was very minimal as only a few transactions failed. We handled them well during the impacted timeframe with no further impact from the incident.
Posted Mar 01, 2024 - 15:39 UTC
Identified
We discovered an issue, where Go-cardless customers are experiencing disruptions in their payment processes due to a technical error affecting collect-invoice and sub-renewal requests. Our team is actively investigating the issue and working on a resolution. We apologize for any inconvenience caused and appreciate your patience as we work to resolve this issue promptly.
Posted Mar 01, 2024 - 10:42 UTC