We are pleased to inform you that the issue affecting our rev-lock.com domain, which caused disruptions in our services due to an AWS-related incident, has been successfully resolved. Our technical team has worked diligently to rectify the situation, and we are now back to normal operations.
We value your business and the trust you place in us. Thank you for your continued support as we strive to provide you with the best service possible.
Posted Oct 19, 2023 - 15:30 UTC
Identified
We regret to inform you that our rev-lock.com domain is currently experiencing an unexpected issue due to disruptions with our AWS hosting services. We understand the inconvenience this may cause, and we want to assure you that our team is actively working to resolve this matter as swiftly as possible.
As a result of this domain unavailability, access to certain services or functionalities may be temporarily impacted.
Posted Oct 19, 2023 - 11:30 UTC
This incident affected: Chargebee RevRec (Accounting Services, Reporting and Analytics).