PayPal Service Degradation

Incident Report for Chargebee

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 13:20 UTC

Investigating

As of 11:32 UTC, PayPal is experiencing a system issue which is impacting multiple payment services. We are continuing to monitor and will post further updates.

Status updates: https://paypal-status.com/incident/production
Posted Nov 18, 2025 - 12:31 UTC
This incident affected: Payment Gateway Processing (Braintree Gateway API, PayPal Payment Services, Adyen).