UK VAT Validation Service Disruption

Incident Report for Chargebee

Update

We have successfully tested Version 2.0 of the HMRC VAT validation API in the sandbox and are now implementing the necessary code changes in Chargebee. We will share further updates as we progress.
Posted Feb 19, 2025 - 06:29 UTC

Update

We are continuing to work on a fix for this issue.
Posted Feb 18, 2025 - 17:24 UTC

Identified

We have identified that HMRC has discontinued Version 1.0 of its VAT validation API, impacting VAT validation for UK businesses. To prevent any disruptions, we have disabled HMRC VAT validation and implemented a temporary format-only validation. Please note that this does not verify VAT registration status.

We have notified affected merchants and are working with HMRC to integrate Version 2 of the API. We will provide updates as we make progress.

For more details, please refer - https://developer.service.hmrc.gov.uk/api-documentation/docs/api/service/vat-registered-companies-api/2.0
Posted Feb 18, 2025 - 08:53 UTC
This incident affects: Third Party Integrations (HMRC VAT Validation Services).