Intermittent 5xx Errors in EU Region

Incident Report for Chargebee

Resolved

On 16th March 2025, an AWS RDS failover event caused two brief periods of elevated 5xx errors due to the temporary unavailability of the database. The disruptions occurred between 07:49 to 07:50 UTC and 07:52 to 07:53 UTC, during which application connectivity to the database was intermittently impacted. As a result, approximately 0.7% of merchants encountered errors, affecting less than 4.9% of total requests in the EU region. The failover was automatically handled by AWS, and services recovered without manual intervention.

We apologize for any disruption this may have caused.

Update: The earlier reported incident window of 07:48 to 08:03 UTC has been updated to reflect the actual impact duration, which was limited to 07:49 to 07:50 UTC and 07:52 to 07:53 UTC based on detailed analysis.
Posted Mar 16, 2025 - 10:58 UTC
This incident affected: API Endpoints (API (EU)).