Invoice Access Issues Impacting Test Sites

Incident Report for Chargebee

Resolved

The issue with loading the Invoice details page has been resolved. Our team has identified and fixed the root cause. We apologize for the inconvenience caused.
Posted Nov 11, 2024 - 14:50 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 11, 2024 - 13:47 UTC

Investigating

Some merchants are encountering an error message stating, "404 Can't find the invoice you're looking for," when attempting to view invoices from the invoice index page. We are working on resolving this issue.
Posted Nov 11, 2024 - 13:10 UTC