Degradation In The Estimate For Subscription Cancellations
Incident Report for Chargebee
Postmortem

Summary: On June 06, 2024, at 04:30 UTC, a deployment introduced a change in the cancel subscription estimate API, making the cancel_reason_code parameter mandatory. This caused the API to trigger 4xx error responses when the cancel_reason_code was not provided, contrary to previous behaviour where this parameter was optional. The issue persisted until June 10, 2024, 04:30 UTC. The problem has been resolved by removing the mandatory check for the cancel_reason_code in the estimate API workflow. No product functionality was impacted, but the system generated 4xx errors for cancel subscription estimates with an empty cancel_reason_code.

Root Cause: The root cause of the issue was a deployment on June 06, 2024, which inadvertently made the cancel_reason_code parameter mandatory for the cancel subscription estimate API when the Subscription cancellation reason was set as mandatory in the settings. This change was not intended and caused the API to return 4xx error responses when the cancel_reason_code was not provided.

Impact: There was no direct impact on product functionality. The cancel subscription estimate API triggered 4xx error responses when the cancel_reason_code was empty.

Next Steps: We have enhanced the error monitoring dashboard to identify any 4xx responses following code deployments to detect and address similar issues in the future quickly. Additionally, we have extended the impact area on automation test cases to ensure broader coverage and early detection of potential problems during the testing phase.

Posted Jun 11, 2024 - 13:45 UTC

Resolved
Between June 6, 2024, 04:30 UTC, and June 10, 2024, 04:30 UTC, a deployment made the cancel_reason_codeparameter mandatory in the cancel subscription estimate API, causing 4xx errors when it was not provided. The issue has been resolved by reverting the parameter to optional. No product functionality was impacted.
Posted Jun 10, 2024 - 06:00 UTC