Avalara Service Degradation

Incident Report for Chargebee

Resolved

This incident has been resolved.
Posted Aug 24, 2026 - 17:47 UTC

Monitoring

Between 14:54 UTC and 15:32 UTC, we experienced intermittent errors with our tax calculation provider, Avalara, which temporarily impacted a few API requests. The errors have stopped, and we are continuing to monitor services to ensure stability.
Posted Aug 24, 2026 - 15:59 UTC
This incident affected: Third Party Integrations (Avalara).