Account Hierarchy Functionality Issues
Incident Report for Chargebee
Postmortem

Incident Summary:

The Account Hierarchy feature experienced an interruption, resulting in customers facing difficulties accessing the Account Hierarchy Dashboard. This interruption affected the ability of customers to manage and view their account hierarchies.

Business Impact:

Customers were unable to manage and view their account hierarchies due to the interruption. We have identified the affected customers and communicated the next steps to them.

Root Cause:

The root cause was traced back to a recent migration performed by Chargebee. This migration inadvertently caused conflicts with the processing capabilities of the Account Hierarchy service leading to a feature lock on the service.

Steps Taken & Way Forward:

The feature settings were manually updated for all the impacted customers, restoring the functionality of the Account Hierarchy feature. To prevent similar issues in the future, the erroneous behaviour has been fixed, and similar workflows will be tested in the automation suite. Additionally, entitlements import functionality is being implemented to avoid service disruptions from migrations.

Posted Jul 12, 2024 - 08:07 UTC

Resolved
The Account Hierarchy feature experienced an interruption, causing difficulties for customers accessing the Account Hierarchy Dashboard. A fix has been implemented to restore services. We apologize for any inconvenience this may have caused.
Posted Jul 05, 2024 - 15:28 UTC