Error processing webhooks
Incident Report for Chargebee
Resolved
The sync process is complete, and the status is successfully updated for most of the webhook calls executed during "12:20 UTC to 14:18 UTC" on January 27, 2022.

Our team will be reaching out to the respective customers for the remaining webhook calls that need additional inputs for closure.
Posted Jan 28, 2022 - 11:39 UTC
Update
We are running a sync process at the backend to update the correct status for webhooks which were marked as “to be scheduled” during the time period “ 12:20 UTC to 14:18 UTC” on January 27, 2022.

We will be reaching out to the customers if any additional inputs are required to resolve the issue.
Posted Jan 28, 2022 - 08:44 UTC
Monitoring
We identified that the webhook status was not getting updated for some of our customers in the US region from 12:20 UTC to 14:18 UTC 27th January 2022. The webhooks that were triggered during this period will have the job status marked as “to be scheduled” in the events UI/API. We have narrowed down the issue to a job management code that was not updating the status in the database even though the webhooks were invoked. The code was triggered to triage and isolate a GC memory incident. The issue has been fixed now and it is not happening for newer events.

We are working on fixing the status of the webhooks during this period. Please reach out to support@chargebee.com for clarifications.
Posted Jan 27, 2022 - 21:35 UTC
This incident affected: Webhooks (Webhooks (US)).