Email Service Degradation

Incident Report for Chargebee

Resolved

This incident has been resolved.
Posted Jun 12, 2026 - 02:12 UTC

Monitoring

Email service has been restored, and new notifications are now being delivered as expected. We will reprocess all queued emails to ensure that any messages delayed during this period are successfully delivered.
Posted Jun 12, 2026 - 02:03 UTC

Update

We are working with our email provider to expedite the resolution. We will provide another update as soon as notifications begin processing again.
Posted Jun 12, 2026 - 01:19 UTC

Update

Our team is following up with the email provider to expedite the restoration of notification services. We will keep you posted as we progress.
Posted Jun 12, 2026 - 00:39 UTC

Update

A fix has been implemented. We are coordinating with our email provider to activate these changes and fully restore notification services.
Posted Jun 12, 2026 - 00:18 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 11, 2026 - 23:53 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 11, 2026 - 23:30 UTC

Investigating

We are investigating an issue with our email provider that is causing delays in system notifications. Our team is working with the email provider to restore normal functionality. We will keep you posted as we progress.
Posted Jun 11, 2026 - 23:15 UTC
This incident affected: Email Notifications (Email Notifications (US), Email Notifications (EU), Email Notifications (AU)).