Adyen Service Degradation

Incident Report for Chargebee

Resolved

This incident has been resolved.
Posted Apr 21, 2025 - 18:41 UTC

Monitoring

Adyen has confirmed that payment processing in the EU has fully recovered as of 19:39 CET. Adyen is continuing to monitor system performance to ensure stability.

Real-time updates: https://status.adyen.com/incident-history#2025
Posted Apr 21, 2025 - 18:11 UTC

Update

Adyen continues to experience degraded performance for payment processing through its EU endpoints. Additional services hosted in their EU data centres are also impacted, including:

Access to the Customer Area
Onboarding Services
Transfer API

Adyen has observed early signs of recovery starting at 19:35 CEST and continues to work on full service restoration.

Real-time Updates: https://status.adyen.com/incident-history#2025
Posted Apr 21, 2025 - 17:45 UTC

Identified

Adyen has confirmed they are currently experiencing a DDoS attack targeting their EU endpoints. Mitigation measures have been initiated across their EU data centres. As a result, customers connecting to Adyen’s EU endpoints may encounter increased error rates and slower response times.

For real-time updates: https://status.adyen.com/incident-history#2025
Posted Apr 21, 2025 - 17:35 UTC

Investigating

We have identified an external issue affecting the Adyen services in Europe since 19:09 CEST. Adyen's team is working on resolving the issue.

For more details, please visit - https://status.adyen.com/incident-history#2025
Posted Apr 21, 2025 - 17:29 UTC
This incident affected: Payment Gateway Processing (Adyen).