AvaTax High Latency Service Disruption
Incident Report for Chargebee
Resolved
This incident has been resolved.
Posted over 2 years ago. Jun 20, 2017 - 21:32 UTC
Identified
One of our upstream provider Avalara is having high latency issues. Merchants who have configured Avalara may face latency issues and/or requests timeouts.
Posted over 2 years ago. Jun 20, 2017 - 19:01 UTC