TaxJar Service Degradation
Incident Report for Chargebee
Resolved
TaxJar conducted scheduled database maintenance on February 18, 2024, between 13:00 and 14:08 UTC. However, the impact window was observed from 13:05 to 13:25 UTC, during which some merchants experienced minimal service interruption in their subscription workflows, leading to API failures. The maintenance activity has been completed, and the system is now functioning normally.

We apologize for any inconvenience caused by this interruption.
Posted Feb 18, 2024 - 14:25 UTC
Investigating
TaxJar integration is currently experiencing service interruptions due to a database upgrade activity in their Infrastructure.

Further updates will be provided as soon as possible. For more details, refer to TaxJar's status page: https://status.taxjar.com/incidents/mtvxw4yps4p5
Posted Feb 18, 2024 - 13:44 UTC
This incident affected: Third Party Integrations (TaxJar).