Application Login Issues

Incident Report for Chargebee

Resolved

This incident has been resolved.
Posted Sep 03, 2026 - 18:40 UTC

Monitoring

The issue has been fixed, and we are monitoring our systems to ensure ongoing stability. We apologize for any disruption this may have caused.
Posted Sep 03, 2026 - 18:10 UTC

Investigating

We are investigating login issues when accessing the Chargebee Admin Portal (https://app.chargebee.com) using email and password; there are no issues with Single Sign-On. We will keep you posted as we progress.
Posted Sep 03, 2026 - 17:36 UTC
This incident affected: Chargebee UI (Admin Console (US), Admin Console (EU), Admin Console (AU)).