Invoice Details Page Loading Issue
Incident Report for Chargebee
Resolved
The issue with loading the Invoice details page has been resolved. Our team has identified and fixed the root cause. The system is now functioning as expected.

We apologize for the inconvenience caused.
Posted Oct 25, 2024 - 10:52 UTC
Investigating
Some customers are facing issues while loading the Invoice details page on the Chargebee UI, Our team is working on fixing this. We will provide updates as soon as we have more information.
Posted Oct 25, 2024 - 10:34 UTC
This incident affected: Chargebee UI (Admin Console (US), Admin Console (EU)).