Retention Login Issues

Incident Report for Chargebee

Resolved

This incident has been resolved.
Posted May 15, 2025 - 06:58 UTC

Monitoring

A temporary fix has been implemented by resetting account settings. We are monitoring the temporary fix to ensure stability.
Posted May 14, 2025 - 15:04 UTC

Identified

Some Chargebee Retention customers are experiencing login issues. Our team is investigating the cause and working on a permanent resolution. Will provide updates as soon as we have more information.
Posted May 14, 2025 - 06:44 UTC
This incident affected: Chargebee Retention (Customer Portal).