Degraded Performance: Outbound Email Notifications

Incident Report for Chargebee

Resolved

We have restored outbound email functionality for test environments. This incident has been resolved.
--
Live sites were not impacted during this service window.
Posted May 29, 2026 - 12:18 UTC

Identified

We are investigating an issue with our email provider that is causing delays in system notifications for test sites. Live sites are not impacted and remain fully operational.

We are working with the provider to restore normal email functionality for our test environments. We will keep you posted as we progress.
Posted May 29, 2026 - 11:40 UTC
This incident affected: Email Services (Sendgrid).