Application latency
Incident Report for Chargebee
Postmortem

On 9th May, Chargebee suffered a major outage between 13:50 UTC and 14:00 UTC. This was due to a bug in the internal monitoring code which resulted in quick spurt in memory consumption in our app servers. This resulted in the app servers becoming unresponsive to incoming requests.

We quickly added app servers to reduce the impact. We also blocked further requests to the particular action immediately. We have also added additional alerts to identify such issues proactively.

We apologize for the disruption caused for your business during this time.

Posted May 10, 2019 - 16:28 UTC

Resolved
This incident has been resolved.
Posted May 09, 2019 - 17:04 UTC
Update
We had noticed latency in connecting to our servers between 14:19 UTC and 14:27 UTC.
Posted May 09, 2019 - 14:36 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 09, 2019 - 14:32 UTC
This incident affected: Chargebee UI (Admin Console (US)), API Endpoints (API (US)), Checkout (Checkout (US)), and Self-Serve Portal (Self-Serve Portal (US)).