NMI Payments Service Disruption
Incident Report for Chargebee
Postmortem

RCA On NMI Payments Service Disruption
Date of Incident: 21-Feb-2024

Incident Summary: Certain merchants experienced transaction failures in the NMI payment gateway with the error message "Custom descriptors are not allowed for this processor" following a release deployed on February 21, 2024. The issue stemmed from Chargebee initiating statement descriptors to the NMI Gateway, resulting in 4xx errors. Despite thorough testing in sandbox environments, the errors only surfaced after the release was deployed to production.

Technical Root Cause Of The Incident: The root cause of the incident was traced back to a recent update in the statement descriptors implemented by Chargebee to the NMI Gateway. This update inadvertently triggered conflicts with the processing capabilities of NMI for certain merchants, resulting in 4xx errors occurring during transaction processing.

The underlying issue stemmed from a flaw in the system's validation process; our system didn't properly check if the statement descriptors were compatible with all processors supported by NMI as per Advanced Merchant Features (AMF). This oversight meant that some merchants were affected without us realizing it. Ultimately, this service disruption caused payment failures.

Though we have monitoring in place for server-side 5xx errors, the absence of appropriate monitoring mechanisms for 4xx errors further delayed the timely identification and resolution of the issue.

What Was The Business Impact? The incident resulted in payment failures, causing disruptions in the checkout, payment collection and renewal workflows.

Remediation And Follow-up Steps: To address the issue, Chargebee took immediate action by disabling the statement descriptor feature for the NMI gateway across all merchants. This feature remained disabled for all merchants using the NMI gateway, and re-enabling it was made available only upon request. Additionally, we implemented relevant alarms to enable swift detection and notification of similar incidents in the future. These measures ensure that we are better equipped to respond promptly to any potential issues, thereby minimizing disruptions to payment processing and safeguarding merchant operations.

Posted Feb 28, 2024 - 11:18 UTC

Resolved
Between Feb 20, 2024 at 14:00 and Feb 21, 2024 at 23:00 UTC, certain merchants experienced issues with their payment transactions in the NMI gateway. The error message displayed was "Custom descriptors are not allowed for this processor". The problem occurred after a recent update in our system added a custom descriptor to transactions. We immediately took remedial steps to disable the statement descriptor feature for the affected gateway. We apologize for any inconvenience this may have caused.
Posted Feb 22, 2024 - 05:00 UTC
This incident affected: Payment Gateway Processing (NMI Payment Gateway).