Adyen Service Degradation

Incident Report for Chargebee

Resolved

This incident has been resolved.
Posted Oct 24, 2025 - 21:04 UTC

Investigating

We have identified an issue outside of our platform resulting in higher error rates for transactions processed through Adyen.
For more details - https://status.adyen.com/incident-history#2025
Posted Oct 24, 2025 - 20:00 UTC
This incident affected: Payment Gateway Processing (Adyen).