PayPal Express Checkout Issue

Incident Report for Chargebee

Resolved

Our team has implemented the necessary fixes, and PayPal Express Checkout is now functioning normally. We appreciate your patience and apologize for any inconvenience caused.
Posted Mar 19, 2025 - 17:41 UTC

Update

We have identified the root cause of the issue and working on implementing a fix.
Posted Mar 19, 2025 - 15:51 UTC

Identified

We are currently experiencing an issue with PayPal Express Checkout, our team is working on resolving the issue.
Posted Mar 19, 2025 - 15:25 UTC
This incident affected: Payment Gateway Processing (PayPal Payment Services).