Spreedly Core API errors

Incident Report for Chargebee

Resolved

After a period of monitoring, Spreedly has not seen any recurrence of this issue.

The lagging data has been resolved and all systems are stabilized and functioning normally with the current data.
Posted Jan 02, 2023 - 01:29 UTC

Monitoring

Spreedly experienced a database capacity limit that resulted in intermittent 5xx errors and lagging data in secondary systems, they have implemented the fix and stabilized the database such that customers should no longer be experiencing any 5xx errors.

Dashboard and secondary systems are still lagging and they are still working on reducing indexes and ensuring the system is fully stabilized. They are prioritizing system stability to support many year-end customer processes and will address the lagging data issue once they are confident that there are no risks to transaction processing.

Until then, Spreedly continues treating this as a SEV-1 incident with the highest priority and monitoring the continuing resolution.
Posted Jan 01, 2023 - 02:46 UTC

Update

Spreedly has made progress on restoring the system to business as usual.

As they continue to implement the resolution, users may still continue to see intermittent 500 errors across multiple endpoints and access to Dashboard and ID may be limited.
Posted Dec 31, 2022 - 14:56 UTC

Update

Spreedly is continuing to work on the restoration of the issue.
Posted Dec 31, 2022 - 12:45 UTC

Identified

The spreedy Gateway team has identified the cause of the service disruption and is working to restore the impacted services.
Posted Dec 31, 2022 - 08:21 UTC

Investigating

Spreedly gateway is having an issue causing intermittent HTTP 500 errors to GET endpoints on Spreedly's Core API. Spreedly Dashboard may be inaccessible to some users.

The functionality to view some information in the Dashboard and ID may not be possible due to internal dependencies related to this incident. For more Incident updates, please visit:https://status.spreedly.com/incidents/14cv89y5vt6h
Posted Dec 30, 2022 - 19:51 UTC