API Service Degradation

Incident Report for Chargebee

Resolved

This incident has been resolved.
Posted Dec 10, 2025 - 06:21 UTC

Monitoring

Between 02:00 and 05:40 UTC, we experienced elevated error rates and increased latencies across all regions. During this period, customers may have encountered 5XX errors and slower response times when making API calls. The underlying issue has been resolved by AWS, and all services have fully recovered.

We will continue to monitor the platform to ensure ongoing stability.
Posted Dec 10, 2025 - 06:14 UTC

Identified

We are experiencing intermittent API timeouts in the US region due to an issue with our cloud service provider. We will share further updates as we make progress.
Posted Dec 10, 2025 - 04:08 UTC
This incident affected: API Endpoints (API (US), API (EU), API (AU)).