Pay with PayPal
Incident Report for Chargebee
Resolved
This incident has been resolved.
Posted about 3 years ago. Oct 30, 2015 - 05:31 UTC
Monitoring
This interruption was caused by a data center power outage. The issue is resolved now. https://twitter.com/PayPal/status/659956682571673601
Posted about 3 years ago. Oct 30, 2015 - 05:31 UTC
Identified
Paypal is working to restore service as quickly as possible. https://twitter.com/PayPal/status/659927440974725121
Posted about 3 years ago. Oct 30, 2015 - 03:19 UTC
Investigating
Checkouts using pay with PayPal are facing issues.
Posted about 3 years ago. Oct 30, 2015 - 03:13 UTC